This project has moved. For the latest updates, please go here.

Speasyform not showing on ribbon

Sep 8, 2016 at 5:53 PM
I'm having a strange issue with speasyforms. I have been using the tool for over a month and all was working great. Today, when I accessed the list ribbon, the speasyforms button was no longer available on the "settings" section. I tried dis-activating and reactivating the add-on but that did not help. I tried deleting the add-on as well as the speasyforms' folder in the site library, re-uploading the script and activating it which also did not resolve the problem.
Has anyone else experienced this behavior?
Sep 20, 2016 at 9:09 PM
I have not seen this issue before. If you go to list settings, is there a link to SPEasyForms there? In general, there are two reasons why the ribbon button wouldn't appear assuming SPEasyForms is installed correctly (and given that you were using it before I assume it is). SharePoint hides the ribbon button if the current user does not have 'Manage Lists' permissions at the site level. Also, I programmatically hide it if the current list is of a type that I know SPEasyForms won't work on (currently only Survey or Data Connection Library are known to be incompatible).

Sep 27, 2016 at 7:35 PM
The same thing has happened to me today. We are on SP server 2010. After using the tool for the past several weeks on a regular SP list, the settings button has disappeared from the list ribbon. Fortunately, the link can still be found in the List Settings. I am a site Admin so I’m not sure why the button disappeared.

Additionally, since installing SPEasyForms I have experienced continuous network issues when working with the tool whereby, after using the tool for a while, I am locked out of our network server. The behavior is the same from any web browser and also from SP Designer when working on the particular list that uses the tool. Any suggestions?

Otherwise – LOVE this tool! Thanks in advance...
Sep 27, 2016 at 9:04 PM
First, on the network issues, there are too many variables, most of them infrastructure related, to speculate much. What exactly does 'locked out of our network server' mean?

As for the ribbon button not appearing, there are two parts to deciding if the ribbon button appears. The first is that the ECB is installed with a permission requirement of Manage Lists, which is declarative, meaning I just put that in the XML that installs the ECB and SharePoint enforces it on the back end. I doubt that is the problem since you are an administrator. The second is that I have some JavaScript that runs on the ECB to decide if it should be shown. This JavaScript gets the current list context using the web services, and if the current list template is 102 (survey) or 108 (discussion) it returns false which hides the button. But, if it cannot get the list context at all, it also returns false which hides the button. Given the network issues you're describing, that may be the culprit.

Marked as answer by mcsheaj on 10/12/2016 at 4:27 PM
Sep 28, 2016 at 12:07 PM

Yes, the network issue is very odd. My SP connection uses my Windows network login so when I open the Intranet or SP Designer my Windows network credentials are being used. What I’ve noticed, since installing the forms tool, is that after I perform any type of action or actions on the list that is using the tool I receive a prompt that I do not have permission to do whatever action I’m trying to perform and to enter my login credentials (time before the prompt varies). However; I am unable to log back in because my Windows account has been locked out. We have numerous SP portal sites and this behavior only happens when I’m performing actions related to the list that is using the tool. At this point the only thing I can guess is that there is a conflict somewhere possibly based on my install of the tool. So I will completely uninstall and then reinstall to see if this fixes that issue.

Regarding the ribbon button issue - I’m not using a Survey or Discussion list – just a custom list. The button was visible and working just fine since the install, several weeks ago, and then all of a sudden disappeared yesterday. Again, this might be another issue whereby there is a conflict somewhere or it does not like another instance of a java script that was applied to the page. However; this is not a big deal since I can still get to the list settings.

Thanks for the quick response!

Nov 28, 2016 at 3:00 PM
As a follow up:
  1. Network issue: this issue had nothing to do with SPEasyForms and was caused by a 3rd party web part column that was not properly set. Once the column was properly set the network lock out connection issue went away.
  2. Ribbon Issue: this issue resolved itself. I was using a custom default form that possibly became corrupt so once I deleted the custom form and re-applied the default form the ribbon came back.